Error after upgrading to php 7.1.1 [K2 Filter & Search module]

Please Log in or Create an account to join the conversation.

#
Hi,
After upgrading to php 7.1.4 I get the following error

0 Too few arguments to function modK2FilterHelper::treeselectbox(), 4 passed in site_path/modules/mod_k2_filter/tmpl/Default/template.php on line 287 and exactly 5 expected

How can I solve it?
Thanks in advance
Chris

Please Log in or Create an account to join the conversation.

#
Hello, Chris.

Please, try to update module to the latest version.

Also, please check if you have no old template overrides.

Please Log in or Create an account to join the conversation.

#
Hi,
For the latest version should I renew my subscription?
If it's a PHP issue should I pay again?

Thanks
Chris

Please Log in or Create an account to join the conversation.

#
Hello, Chris.

It seems you use a version from 2016 year. Yes, you need to renew it.

It is tested with latest php version and there are no such errors.