Joomla Articles Good Search - Timezone Problem

Please Log in or Create an account to join the conversation.

#
We've got a custom field setup which is a date field.

When using the good search module with this field it says no results even though the date entered matches the date in the field.

I suspect its a timezone problem as when the previous day is used to search the results are shown

Please Log in or Create an account to join the conversation.

#
Hello, Robert.

Thanks for your post.

Could you tell me which timezone you used in Joomla configuration? Example date which you used in article's custom field?

Which exactly field type you used in Articles Good Search module?

Please Log in or Create an account to join the conversation.

#
So our server is based in the USA but the timezone in the joomla config is London.

The custom field is a calendar with no time

The date of the article is 13th April 2019

when searching for the 13th April it shows no results but searching for the 12th April shows the article

Please Log in or Create an account to join the conversation.

#
Robert,

Please, try to download fixed version of the module.

Please Log in or Create an account to join the conversation.

#
Thanks that's fixed it!

Please Log in or Create an account to join the conversation.

#
Hi we are having the problem again with search showing results that it shouldn't

Please Log in or Create an account to join the conversation.

#
Hello, Robert.

Could you explain which problems you have now? Can you provide an example on your site?

Please Log in or Create an account to join the conversation.

#
Yes, it is possible to type over skype or email as I don't want to show details on a public forum?

Please Log in or Create an account to join the conversation.

#
Sure, please contact me via email - This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

#
thanks email sent