[Articles Good Search module] Pagination not working

Please Log in or Create an account to join the conversation.

#
Hi.
First of all, thank you for this great extension that provides an interesting replacement to the late Fieldsattach.
I have a problem however: the pagination is not working. No matter which result page you try to access, it's always showing page 1. The url is correct (limitstart=10, limitstart=20, ...) but it's always the first 10 results showing.

The template select option does not work either (maybe it's related): the "card" display is briefly shown, then it reverts to the list display.

It's not related to the site template as I tested with the Protostar template and there is no JS error reported in the console.

Joomla! version is the latest (3.9.3) - module version is v1.2.1_b0004

Please Log in or Create an account to join the conversation.

#
Hello, Jean-Francois.

Thanks for your post.

Sorry, but I can't get the same issues on my local site. Maybe it is some conflict with another extensions.
Also, it uses another keys in the url for pagination, e.g. &page-start=5 (not limitstart).

Can you provide me admin and ftp access to your site for debug it?

Please Log in or Create an account to join the conversation.

#
Well, that's interesting: if I don't use any URL rewriting (which was the situation when I reported the issue), the pagination uses "&limitstart=x", and you're stuck on page 1.

If you use URL rewriting however (Joomla's), then you get "&page-start=x" and the pagination works.

It's probably something related to Joomla! 3.9.x that introduced some changes in the router.

Most people will use URL rewriting but you may want to look at this issue anyway.

In any case, thanks for your help.

Please Log in or Create an account to join the conversation.

#
Sorry, I edited my previous post. I did not see you have answered already.

Please Log in or Create an account to join the conversation.

#
Ok, thank you. Yes, I see it when 'Search Engine Friendly URLs' parameter disabled in Joomla configuration.

I will debug it and let you know asap.

Please, you can send me an email or private message here joomcar.net/forum/profile/358-molotow

Please Log in or Create an account to join the conversation.

#
Hello, Jean-Francois.

Please, try to download new fixed module from the site.