All extensions are free now. Because it was coded by Russians.

K2 Filter @ search template problems

Please Log in or Create an account to join the conversation.

#
Good day,

I just installed the new update today and I'm having problems with the Field connection parameters on the "Selectize" sub-template.

When I connect the field "Category=>Sub Category" or "Province=>City" the child drop down doesn't work or load I would really like help with this because the template looks great.

Check out the website www.coreinnovations.co.za then you will see what I mean, the default template works but doesn't look great for me.

Please help

Please Log in or Create an account to join the conversation.

#
Hello, Dawid.

Could you tell me which connection type you use? (single or mass). Please, give me an example of parent and child fields values you used.

Please Log in or Create an account to join the conversation.

#
Hai, check out the image I sent.

I used Mass connection type, in the image it will show the parent type and child I used, it worked on the previous version and on the one now on the default template but not on the on "Selectize".

This message has an attachment file.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

#
Hello, Dawid.

Please, try to replace this file with attached one - tmpl\Selectize\elements\connected_mass.php

This message has an attachment file.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

#
Hey, it work but now the problem is it would not allow me to add another parent and child only allows one.

Like: Category=>Sub-Category

it will allow this.

but not: Category=>Sub-Category
Province=>City

the first parent doesn't want to load the Child only the second parent that loads it child category.

See the website for the problem.

Thank you for the support so far.

Please Log in or Create an account to join the conversation.

#
Hello, Dawid.

Please, try to check it with attached file.
modules\mod_k2_filter\tmpl\Selectize\elements\connected_mass.php
This attachment is hidden for guests.
Please log in or register to see it.

This message has an attachment file.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

#
Hey, it worked but I had to change the code on row 188 to where you said

var next = jQuery(this).parents('.k2filter-cell').next().find("select.connected");

to

var next = jQuery(this).parents('.k2filter-cell').nextAll().find("select.connected");

But so far it is working without any problems.

Thank you again

Please Log in or Create an account to join the conversation.

#
Dawid,

Ok, great that it helped you.

Thank you. All the best!