The Article good search issue

Please Log in or Create an account to join the conversation.

#
The Article good search module is not working. The page is not displaying properly.
I'm using Joomla3 and PHP 8.

It works if I change the version to PHP 7.3. Any suggestion? Please help!

bit.ly/3eZ8V1z

Please Log in or Create an account to join the conversation.

#
Hello,

It will be fixed through email conversation.

Please Log in or Create an account to join the conversation.

#
Hello,

i have the same problem. When i activate PHP 8.1 on my server the page with blog articles display this error : in_array(): Argument #2 ($haystack) must be of type array, null given

If i activate PHP 7.4.x it's ok.

I have the last version of Article good search and Joomla 3.10.5

What can i do please ?

Best regards.

Please Log in or Create an account to join the conversation.

#
Hello, Florent.

Please, send me details via email and link where I can check it if possible.
When you enable Debug mode in Joomla settings, then this should show full error trace.

Please Log in or Create an account to join the conversation.

#
Hello, i send you by email the report of Joomla debug.

Thanks

Please Log in or Create an account to join the conversation.

#
Sorry, I am not see it.

Please Log in or Create an account to join the conversation.

#
It's a production site so for now I left PHP 7.4.x. That's why you didn't see the error.

I just enabled PHP in version 8.1.2 so you can see the problem on this page.

Thank you

Please Log in or Create an account to join the conversation.

#
Sorry, can you send me a link?

Please Log in or Create an account to join the conversation.

Please Log in or Create an account to join the conversation.

#
Please, enable debug mode in Joomla general settings for get full error trace.