Php warning message [K2 Filter & Search module]

Please Log in or Create an account to join the conversation.

#
I am getting warnings. I hope this can be fixed. Just installed latest version.
Warning I get when intiating search.

Warning: count(): Parameter must be an array or an object that implements Countable in /home3/malawvel/public_html/plugins/jsnpagebuilder/defaultelements/module/module.php on line 216

Warning: count(): Parameter must be an array or an object that implements Countable in /home3/malawvel/public_html/plugins/jsnpagebuilder/defaultelements/module/module.php on line 216

malawitravel.biz/discover-malawi/your-ma...ravel-assistant.html

Thank you! Great product!

Please Log in or Create an account to join the conversation.

#
Hello, Abraham.

Thank you.

Please, try to change Joomla general parameters and change error reporting level.
Sorry, but this messages generated by other extension and we can't fix it - plugins/jsnpagebuilder

Please Log in or Create an account to join the conversation.

#
Hi, indeed i realized that. Error reporting is none, so reported this to Joomlashine.
I see in my result listing created date. But it is set to hide in the list. Am i missing something? for now i have overridden to not display.
for the search is it possible to limit the number of words/character that you display?
Again great product!!!

Please Log in or Create an account to join the conversation.

#
Hello, Abraham.

You can remove created date in this file (create override first) -
plg_articles_good_search\template\com_content\gsearch_blog_item.php
Find and remove this block - <li class="created">

For limit into text in search results list items, you can use this module's parameter - "Intro text limit"

You can adjust search results template in "Search results template parameters" section;
Template files located here - plugins/system/plg_articles_good_search/template/com_content/
Search results template files can be overrided in this folder - /templates/your_template/html/com_content/ (need to copy all template files).

Please Log in or Create an account to join the conversation.

#
i do not see this parm to limit.

where should i set this parameter?
For limit into text in search results list items, you can use this module's parameter - "Intro text limit"

Please Log in or Create an account to join the conversation.

#
Hello, Abraham.

It should be in the module parameters. Could you specify, which exactly module you are using?

Please Log in or Create an account to join the conversation.

#
K2 Filter & Search module
1.57

Please Log in or Create an account to join the conversation.

#
Sorry, it is no such parameter for K2 Filter generic search results.

You can modify this template file (create override first) - plg_k2filter\K2Filter\templates\filter.php

Or, you can use K2 category template for search results page, then it will use K2 category parameters for text limit.