link in intro does not work

Please Log in or Create an account to join the conversation.

#
hello

I have some links in introtext that are leading either to a file or to an url.
They are made by JCE

On results of Articles good search , it appears but not as a link




Is this a good search issue or a JCE issue ?
Attachments:

Please Log in or Create an account to join the conversation.

#
Hello, Serge.

Yes, it can be because "Articles Good Search" makes clearance for count characters for text limit.
Try to set "Intro text limit" parameter to 0

Also, you can modify (override) this template file - plugins\system\plg_articles_good_search\template\com_content\gsearch_blog_item.php

Find <h2><h3>
Then append <a> or any other tags you want to pass.

Please Log in or Create an account to join the conversation.

#
thanks, it works without text limit
scond solution does not work because, I think, the tag is <a href .....> and not just <a>

but why do you clear intro text when text limit is on ??

Please Log in or Create an account to join the conversation.

#
Hello, Serge.

Ok, great.

Php strip_tags accept exactly <a> tag, so it should be fine. Maybe it is just not your case.

This needed for count text characters length and also for operate with images in text.
You can disable it in your custom template file gsearch_blog_item.php
Find and remove the following block at the top:
if ($image_type == "intro" || $ImagesTab) {
	$item->introtext = trim(strip_tags($item->introtext, '<h2><h3><a><b>'));
}
if($model->module_params->text_limit) {
   ....................
}