Article Good Search slider

Please Log in or Create an account to join the conversation.

#
Hi,

Your extension has really helped us but I encountered an issue that I cant seem to figure out by myself.
I would like to add a slider (like the one for the price in the demo) but I am unable to get it to work.

Find attached my fields, left one using text, right one using integer field type.

Thanks.
Attachments:

Please Log in or Create an account to join the conversation.

#
Hello, Enry.

It can be some javascript issue on your site. Can you send me a link for check it?

Please Log in or Create an account to join the conversation.

#
Okay I managed to get it working

Please Log in or Create an account to join the conversation.

#
Okay, I have a new problem with the slider. I would like to be able to search between values from 0 to 100,000,000 but whenever I do this, I am unable to access the field settings in the article. Is there a way to be able to search from such a large range?

Thanks

Please Log in or Create an account to join the conversation.

#
Hello, Enry.

Please, try to use text custom field and then just define a values for each article.

Please Log in or Create an account to join the conversation.

#
It works perfectly now thanks. Is it possible to add a prefix to the range such as a euro symbol?
Thanks

Please Log in or Create an account to join the conversation.

#
Hello, Enry.

Yes, you can override and modify this template file - modules\mod_articles_good_search\tmpl\Default\fields\custom_fields\slider.php

Find this part of code (two times):
ev.value[0] + ' - ' + ev.value[1]

And replace with:
'€' + ev.value[0] + ' - €' + ev.value[1]

Please Log in or Create an account to join the conversation.

#
Okay, this works but there are a couple of issues. All the search fields now appear above one another instead of side by side. The Euro symbol only appears when you move one of the sliders, if it could appear when the page loads, that would be great. Would it also be possible to add another prefix on the search results?

Thank you, your support is greatly appreciated.

Please Log in or Create an account to join the conversation.

#
Hello, Enry.

Please, try to check "Columns" module's parameter and set it to "Auto". Otherwise, please send me a link for check it.

Sorry, yes for fix it on initial page loading you need to modify this part:
<?php echo $active_min; ?> - <?php echo $active_max; ?>

Replace with:
€<?php echo $active_min; ?> - €<?php echo $active_max; ?>

Please Log in or Create an account to join the conversation.

#
Columns were already set to auto. Here is the page, but its effecting all search modules on the website. www.italiamalta.net/gare-appalto-malta/tender2020.html