Articles Good Search - standard search mode with sh404sef issue

Please Log in or Create an account to join the conversation.

#
Hello.
We have one issue that we are not able to resolve.

Joomla module named "New cars finder" is located on the homepage, set to "search_type": standard, "Menu Itemid for search results page" to Menu item "new-cars". That menu item refers to: web.sample.com/new-cars/ when clicked directly redirects browser to web.sample.com/new-cars/ That is correct.

But when I click the search button on homepage, browser is redirected correctly to page with new cars, results are shown, breadcrumbs menu is also web / new-cars , menu item is selected as active, but href is web.sample.com/?field5%5B%5D=volkswagen .

So I mean WITHOUT "/new-cars/"

That then throws some problems when sorting, the user is redirected to homepage, etd...

Can you help us please?

Thank you,

Zdenek

Please Log in or Create an account to join the conversation.

#
Hello, Milan.

By default, it uses the same page as initial for show search results. So, if you make search from homepage, then it will be homepage in the url.

But, you can change form action in the template file here - modules\mod_articles_good_search\tmpl\Default\template.php

E.g. find this part of code <form action="
And replace with <form action="/new-cars

If it not help you, can you send me a link for check it?

Please Log in or Create an account to join the conversation.

#
Great job! That's it ;)

Thanks in advice!

Zdeněk