Joomla Article Images upload and gallery plugin

Please Log in or Create an account to join the conversation.

#
Hi,

I've just downloaded this plugin to see it will be able to accomplish what I need.

However on viewing the Joomla article in which I've added a gallery I get 2 warnings.

1. In a table at the top of the page:

( ! ) Notice: Undefined index: gallery_template in F:\www\jacksons1\plugins\system\imagestab\imagestab.php on line 418
Call Stack
# Time Memory Function Location
1 0.0011 408176 {main}( ) ...\index.php:0
2 0.1451 1330344 Joomla\CMS\Application\SiteApplication->execute( ) ...\index.php:49
3 0.1451 1330344 Joomla\CMS\Application\SiteApplication->doExecute( ) ...\CMSApplication.php:196
4 0.3802 2109600 Joomla\CMS\Application\SiteApplication->dispatch( ) ...\SiteApplication.php:233
5 0.4098 2151688 Joomla\CMS\Component\ComponentHelper::renderComponent( ) ...\SiteApplication.php:194
6 0.4128 2164392 Joomla\CMS\Component\ComponentHelper::executeComponent( ) ...\ComponentHelper.php:377
7 0.4129 2181448 require_once( 'F:\www\jacksons1\components\com_content\content.php' ) ...\ComponentHelper.php:402
8 0.4202 2191552 ContentController->execute( ) ...\content.php:43
9 0.4202 2191552 ContentController->display( ) ...\BaseController.php:710
10 0.5343 2374296 ContentController->display( ) ...\controller.php:118
11 0.5420 2387880 ContentViewArticle->display( ) ...\BaseController.php:672
12 0.7358 2742248 JEventDispatcher->trigger( ) ...\view.html.php:199
13 0.7358 2742320 plgSystemImagesTab->update( ) ...\dispatcher.php:160
14 0.7359 2742320 plgSystemImagesTab->onContentBeforeDisplay( ) ...\event.php:70
15 0.7364 2743288 plgSystemImagesTab->renderGallery( ) ...\imagestab.php:381


And the second as free text that's rendered just below the Joomla Article's details block, but above the slider generated by the plugin:

( ! ) Warning: count(): Parameter must be an array or an object that implements Countable in F:\www\jacksons1\plugins\system\imagestab\imagestab\templates\article\slider.php on line 57 Call Stack #TimeMemoryFunctionLocation 10.0011408176{main}( )...\index.php:0 20.14511330344Joomla\CMS\Application\SiteApplication->execute( )...\index.php:49 30.14511330344Joomla\CMS\Application\SiteApplication->doExecute( )...\CMSApplication.php:196 40.38022109600Joomla\CMS\Application\SiteApplication->dispatch( )...\SiteApplication.php:233 50.40982151688Joomla\CMS\Component\ComponentHelper::renderComponent( )...\SiteApplication.php:194 60.41282164392Joomla\CMS\Component\ComponentHelper::executeComponent( )...\ComponentHelper.php:377 70.41292181448require_once( 'F:\www\jacksons1\components\com_content\content.php' )...\ComponentHelper.php:402 80.42022191552ContentController->execute( )...\content.php:43 90.42022191552ContentController->display( )...\BaseController.php:710 100.53432374296ContentController->display( )...\controller.php:118 110.54202387880ContentViewArticle->display( )...\BaseController.php:672 120.73582742248JEventDispatcher->trigger( )...\view.html.php:199 130.73582742320plgSystemImagesTab->update( )...\dispatcher.php:160 140.73592742320plgSystemImagesTab->onContentBeforeDisplay( )...\event.php:70 150.73642743288plgSystemImagesTab->renderGallery( )...\imagestab.php:381 160.80362769696require( 'F:\www\jacksons1\plugins\system\imagestab\imagestab\templates\article\slider.php' )...\imagestab.php:562 " style="margin: 20px 0; min-height: 100px; ">


I realise they are warnings, that I can turn off, but problem free code is always preferable :)

I'm using version 3.9.22 of joomla on php version 7.3.21 via WAMP.

If there's a solution, please let me know.

Regards, Brendan

Please Log in or Create an account to join the conversation.

#
Hello, Joe.

Thanks for your post.

Please, try to update the plugin with latest version (just updated).

Please Log in or Create an account to join the conversation.

#
Hi,

Tested.

The errors have now disappeared :)

Thank you.